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Getting	Started	with	CATIA	V5-6R2015
Introduction	to	CATIA	V5-6R2015
CATIA	V5-6R2015	is	a	parametric	and	feature-based	system	that	allows	you	to	create	3D
parts,	assemblies,	and	2D	drawings.	The	design	process	in	CATIA	V5	is	shown	below.

Workbenches	in	CATIA	V5-6R2015
CATIA	V5	offers	many	workbenches	to	perform	various	design	processes.	For	example,
CATIA	V5	provides	you	with	the	Generative	Sheetmetal	Design	workbench	to	design	a
sheet	metal	part.	Likewise,	 there	are	many	workbenches	to	perform	advanced	operations
such	are	static	analysis,	mold	design,	automotive	design,	and	so	on.	However,	in	this	book
we	 cover	 the	 basic	 workbenches	 such	 as	 Sketcher,	 Part	 Design,	 Assembly	 Design,
Drafting,	 Generative	 Sheetmetal	 Design,	 and	 Generative	 Shape	 Design.	 A	 brief
introduction	to	these	workbenches	is	given	next.

	

Part	Design
The	 Part	 Design	 workbench	 provides	 you	 with	 commands	 to	 create	 parametric	 solid
models.	You	can	activate	this	workbench	by	clicking	Start	>	Mechanical	Design	>	Part
Design	on	the	Menu	bar.	To	create	solid	models,	you	must	draw	parametric	sketches	in	the
Sketcher	 workbench,	 and	 then	 convert	 them	 into	 solids.	 However,	 you	 can	 add	 some
additional	features	to	the	solid	models,	which	do	not	require	sketches.

	



Assembly	Design
The	Assembly	Design	workbench	(click	Start	>	Mechanical	Design	>	Assembly
Design)	has	commands	to	combine	individual	parts	in	an	assembly.	There	are	two	ways	to
create	an	assembly.	The	first	way	is	to	create	individual	parts	and	assemble	them	in	the
Assembly	Design	Workbench	(Bottom-up	assembly	design).	The	second	way	is	to	start	an
assembly	file	and	create	individual	parts	in	it	(Top-down	assembly	design).

	

Drafting
The	Drafting	workbench	(click	Start	>	Mechanical	Design	>	Drafting)	has	commands
to	create	2D	drawings,	which	can	be	used	for	the	manufacturing	process.	There	are	two
ways	to	create	drawings.	The	first	way	is	to	generate	the	standard	views	of	a	3D
component	or	assembly.	The	second	way	is	to	sketch	the	drawings	manually.

	

Generative	Sheetmetal	Design
The	Generative	Sheetmetal	Design	workbench	(click	Start	>	Mechanical	Design	>
Generative	Sheetmetal	Design)	has	commands	to	create	sheet	metal	geometry.	You	can
create	sheet	metal	model	either	by	building	features	in	a	systematic	manner	or	by
converting	a	part	geometry	in	to	a	sheet	metal.

	

Generative	Shape	Design
The	Generative	Shape	Design	workbench	(click	Start	>	Shape	>	Generative	Shape
Design)	has	commands	to	create	complex	geometries,	which	cannot	be	created	by	using



the	commands	in	the	Part	Design	workbench.	You	can	create	a	surface	geometry,	and
then	convert	it	into	a	solid	geometry.	A	surface	is	an	infinitely	thin	feature,	which	acts	as	a
reference.	Whereas,	a	solid	geometry	has	properties	such	as	weight,	center	of	gravity,	and
so	on.

	

Parametric	Modeling	in	CATIA	V5
In	CATIA	V5,	parameters,	dimensions,	or	constraints	control	everything.	For	example,	if
you	want	to	change	the	position	of	the	hole	shown	in	figure,	you	need	to	change	the
dimension	or	constraint	that	controls	its	position.

The	parameters	and	constraints	that	you	set	up	allow	you	to	have	control	over	the	design
intent.	The	design	intent	describes	the	way	your	3D	model	will	behave	when	you	apply
dimensions	and	constraints	to	it.	For	example,	if	you	want	to	position	the	hole	at	the	center
of	the	block,	one	way	is	to	add	dimensions	between	the	hole	and	the	adjacent	edges.
However,	when	you	change	the	size	of	the	block,	the	hole	will	not	be	at	the	center.

You	 can	 make	 the	 hole	 to	 be	 at	 the	 center,	 even	 if	 the	 size	 of	 the	 block
changes.	To	do	this,	you	need	to	delete	the	dimensions	and	create	a	diagonal
line.	 Next,	 apply	 the	Midpoint	 constraint	 between	 the	 hole	 point	 and	 the
diagonal	 line.	 Now,	 even	 if	 you	 change	 the	 size	 of	 the	 block,	 the	 hole	will
always	remain	at	the	center.



	

Associativity
The	other	big	advantage	of	CATIA	V5	is	the	associativity	between	parts,	assemblies	and
drawings.	When	you	make	changes	to	the	design	of	a	part,	the	changes	will	take	place	in
any	assembly	that	it	is	a	part	of.	In	addition,	the	2D	drawing	will	update	automatically.



File	Types	in	CATIA	V5
CATIA	V5	offers	three	main	file	types:

	

CATPart:	This	type	of	file	has	geometry	of	individual	part.	The	files	created	in	Sketcher,
Part	Design,	Generative	Sheetmetal	Design,	and	Wireframe	and	Surface	Design,	and
so	on	will	have	this	extension.

CATProduct:	This	type	of	file	is	an	assembly	of	one	or	more	parts.	In	fact,	it	is	a	link	of
one	or	more	parts.

	

CATDrawing:	The	files	created	in	the	Drafting	workbench	have	this	extension.



Starting	CATIA	V5-6R2015
To	start	CATIA	V5-6R2015,	click	the	CATIA	V5-6R2015	icon	on	your	computer	screen
(or)	click	Start	>	All	Programs	>	CATIA	>	CATIA	V5-6R2015.		If	you	are	working	in
Windows	8,	then	click	the	Windows	icon	on	the	bottom	left	corner.	Click	the	down	arrow
on	 the	Start	screen.	On	 the	Apps	screen,	go	 to	 the	CATIA	section	and	click	 the	CATIA
V5-6R2015	icon.



User	Interface
The	following	image	shows	the	CATIA	V5-6R2015	application	window.

	

	

Various	components	of	the	user	interface	are:

Standard	Toolbar
This	 toolbar	 has	 some	 commonly	 used	 commands	 such	 as	 New,	Open,	 Save,	 Undo,
Redo,	Copy,	and	so	on.

	

	

Start	Menu
The	Start	Menu	appears	when	you	click	on	the	Start	button	located	at	the	top	left	corner
of	 the	 window.	 The	 Start	 Menu	 has	 a	 list	 of	 workbenches.	 You	 can	 switch	 between
different	workbenches	using	this	menu.



Menu	bar
Menu	bar	is	located	at	the	top	of	the	window.	It	has	various	options	(menu	titles).	When
you	click	on	a	menu	title,	a	drop-down	appears.	Select	any	option	from	this	drop-down.

Toolbar
A	toolbar	is	a	set	of	commands,	which	help	you	to	perform	various	operations.	Various
toolbars	available	in	different	workbenches	are	given	next.

	

Part	Design	Toolbars

.
Starts	the	Sketcher	workbench

This	 toolbar	 has	 commands	 to	 create

sketch	elements

This	toolbar	has	commands	to	apply
constraints	between	sketch	elements.

This	toolbar	has	commands	to	modify
sketch	elements.

This	 toolbar	has	options	 to	 filter	 the	 type
of	element	that	can	be	selected.

This	 toolbar	has	options	 that	 help	you	 to
create	sketch	elements.

Exits	the	workbench.

	

This	toolbar	has	commands	to	create	solid
features	based	on	the	sketch	geometry.

	



This	toolbar	has	commands	to	replicate
solid	features.

This	toolbar	has	commands	to	additional
features,	which	do	not	require	any	sketch.

This	toolbar	has	commands	to	measure
physical	properties	of	the	geometry.

Sections	 the	 geometry	 to	 view	 its	 inside
portion.

Applies	material	to	a	solid	geometry.

This	toolbar	has	commands	to	convert	a
surface	model	in	to	solid.

This	toolbar	has	commands	to	zoom,	pan,
rotate,	or	change	the	view	of	a	3D	model.

Assembly	Design	Toolbars

This	toolbar	has	commands	to	create
components	or	insert	existing	components
into	an	assembly.

This	toolbar	has	commands	to	apply
constraints	between	components.

This	toolbar	has	commands	to	manipulate
the	position	of	a	component.

Generative	Shape	design	Toolbars

This	toolbar	has	commands	to	create	three
dimensional	curves	and	wireframe
geometry.

This	 toolbar	 has	 commands	 to	 create
surfaces.



	

The	commands	on	this	toolbar	help	you
modify	or	transform	surfaces.

Generative	Sheetmetal	Design	Toolbars

The	commands	on	this	toolbar	help	you	to
create	walls	of	a	sheet	metal	part.

The	commands	on	this	toolbar	help	you	to
apply	bends	to	a	sheet	metal	wall.

This	toolbar	has	commands	to	add	cuts
and	stamps	to	a	sheet	metal	part.

This	toolbar	has	commands	to	create
rolled	sheets	and	funnels.

This	toolbar	has	commands	to	switch
between	folded	and	unfolded	views	of	a
sheet	metal	part.

Drafting	Toolbars

	

This	toolbar	has	commands	to	generate
standard	views	of	a	3D	geometry.

This	toolbar	has	commands	to	generate
dimensions	and	balloons.

The	commands	on	this	toolbar	will	help
you	to	add	a	new	sheet,	drawing	view	and
so	on.

The	commands	on	this	toolbar	help	you	to
add	driven	dimensions	to	the	drawing
views.

This	toolbar	has	commands	to	add
centerlines,	hatches,	and	arrows	the
drawing	view.



	

Some	toolbars	are	not	visible	by	default.	To	display	a	particular	toolbar,	right-click	on	any
toolbar,	and	then	select	the	toolbar	name	from	the	list	displayed.	

	

Status	bar
This	 is	available	below	 the	graphics	window.	 It	 shows	 the	prompts	and	 the	action	 taken
while	using	the	commands.

Specification	Tree
Contains	the	list	of	operations	carried	while	constructing	a	part.

	



Dialogs
When	you	execute	any	command	in	CATIA	V5,	the	dialog	related	to	it	appears.	A	dialog
has	various	options.	The	following	figure	shows	various	components	of	a	dialog.

This	textbook	uses	the	default	options	on	the	dialog.

Mouse	Functions
Various	functions	of	the	mouse	buttons	are:

Left	Mouse	button	(MB1)
When	you	double-click	the	left	mouse	button	(MB1)	on	an	object,	the	dialog	related	to	the
object	appears.	Using	this	dialog,	you	can	edit	the	parameters	of	the	objects.

Middle	Mouse	button	(MB2)
Press	the	middle	mouse	and	drag	the	mouse	to	pan	the	view.



Right	Mouse	button	(MB3)
Click	this	button	on	an	object	to	open	the	shortcut	menu	related	to	it.			



Background
To	change	the	background	color	of	the	window,	click	Tools	>	Options	on	the	Menu	bar.
On	the	Options	dialog,	click	General	>	Display	on	the	left	side.	Click	the	Visualization
tab	and	set	the	colors	of	various	element	types.

	

	

To	change	the	color	of	sketch	elements,	click	Mechanical	Design	>	Sketcher	on	the	left
side,	and	then	change	the	Default	color	of	the	elements.

	

Shortcut	Keys

CTRL+Z	 	 	 	 	 	 	 	
																

Undo



CTRL+Y																								 Redo

CTRL+S																								 Save

F1			 CATIA	V5	Help

CTRL+N																								 New	File

CTRL+O																								 Open	File

CTRL+P																								 Plot

Shift+Left Rotate	To	The	Left	

Shift+Right Rotate	To	the	Right	

Shift+Up Rotate	Upward	

Shift-Down Rotate	Downward	

Alt+F8 Start	Macros	

Alt+F11 Visual	Basic	

Ctrl+Page	Up Zoom	In	

Ctrl+Page	Down Zoom	Out	

Ctrl+Left Pan	Left	

Ctrl+Right Pan	Right	

Ctrl+Up Pan	Up	

Ctrl+Down Pan	Down	

Ctrl+Shift+Left Rotate	 Around	 Z	 Axis
clockwise	

Ctrl+Shift+Right Rotate	 Around	 Z	 Axis
CounterClockwise	

Ctrl+Tab Swap	Windows	

Ctrl+F Search	



Ctrl+U Update

Ctrl+X Cut	

Ctrl+C Copy

Ctrl+V Paste	

	

Questions
1.	 Explain	how	to	display	hidden	toolbars.
2.	 What	is	the	design	intent?
3.	 Give	 one	 example	 of	 where	 you	 would	 establish	 a	 constraint	 between	 a	 part’s

features.
4.	 Explain	the	term	‘associativity’	in	CATIA	V5.
5.	 List	the	procedure	to	access	CATIA	V5	Help.
6.	 How	can	you	change	the	background	color	of	the	graphics	window
7.	 How	can	you	activate	the	shortcut	Menu?
8.	 How	is	CATIA	V5	a	parametric	modeling	application?

	

	

	

	

	

	

	

	

	

	

	

	

	

	

	

	

	



	

	

	

	





Sketcher	Workbench
This	chapter	 covers	 the	methods	and	commands	 to	create	 sketches	used	 in	 the	Sketcher
Workbench.	In	CATIA	V5,	you	can	create	sketches	in	the	Sketcher	Workbench.	You	will
learn	to	create	sketches	in	this	Workbench.

	

In	 CATIA,	 you	 create	 a	 rough	 sketch,	 and	 then	 apply	 dimensional	 and	 geometric
constraints	 that	define	 its	 shape	and	size.	The	dimensional	constraints	define	 the	 length,
size,	 and	 angle	 of	 a	 sketch	 element,	 whereas	 geometric	 constraints	 define	 the	 relations
between	sketch	elements.

	

The	topics	covered	in	this	chapter	are:

	

Sketching	in	Sketcher	Workbench
Use	geometric	and	dimensional	constraint	to	control	the	shape	and	size	of	a	sketch
Learn	sketching	commands
Learn	commands	and	options	that	help	you	to	create	sketches	easily

	

Sketching	in	the	Sketcher	Workbench
Creating	sketches	in	the	Sketcher	Workbench	is	very	easy.	You	have	to	activate	the	Sketch
command,	and	then	define	a	plane	on	which	you	want	to	create	the	sketch.

	

1.	 On	the	Sketcher	toolbar,	click	the	Sketch	icon	(or)	click	Insert	>	Sketcher	>	Sketch
on	the	menu.

2.	 Click	on	any	of	the	reference	planes	located	at	the	center	of	the	graphics	window.

3.	 You	can	now	start	drawing	sketches	on	the	selected	plane.



4.	 After	creating	the	sketch,	click	Workbenches	Toolbar	>	Exit	Workbench	 to	exit	 the
sketch.

	

	

The	following	figures	show	the	orientation	of	the	part	when	the	sketch	is	created	on	three
different	planes.

	

XY	plane

YZ	Plane

ZX	Plane



Draw	Commands
CATIA	V5	provides	you	with	a	set	of	commands	to	create	sketches.	These	commands	are
located	on	the	Profile	toolbar.

	

	The	Profile	command
This	is	the	most	commonly	used	command	while	creating	a	sketch.

	

1.	 To	activate	this	command,	click	the	Profile	button	on	the	Profile	toolbar	(or)	click
Insert	>	Profile	>	Profile	on	the	menu.	As	you	move	the	pointer	in	the	graphics
window,	you	will	notice	the	X	and	Y	coordinates	of	the	pointer.

2.	 To	create	a	line,	click	in	the	graphics	window,	move	the	pointer	and	click	again.	After
clicking	 for	 the	 second	 time,	 you	 can	 see	 an	 end	 point	 is	 added	 and	 another	 line
segment	is	started.	This	is	a	convenient	way	to	create	a	chain	of	lines.

3.	 Continue	to	click	to	add	more	line	segments.



The	Profile	command	can	also	be	used	to	draw	arcs	continuous	with	lines.

	

4.	 On	the	Sketch	Tools	toolbar,	click	the	Tangent	Arc	button.

	

	

5.	 Move	the	pointer	and	click	to	draw	an	arc	tangent	to	the	previous	line.

6.	 On	the	Sketch	Tools	toolbar,	click	the	Three	Point	Arc	button	to	create	an	arc	normal
to	the	previous	line.

	

	

7.	 Define	the	second	and	third	points	of	the	arc.



To	delete	a	line,	select	it	and	press	the	Delete	key.	To	select	more	than	one	line,	press	the
Ctrl	key	and	click	on	multiple	line	segments;	the	lines	will	be	highlighted.	You	can	also
select	multiple	lines	by	dragging	a	box	from	left	to	right.	Press	and	hold	the	left	mouse
button	and	drag	a	box	from	left	to	right;	the	lines	inside	the	box	boundary	will	be	selected.

	

	Three	Point	Arc
This	command	creates	an	arc	by	clicking	three	points	in	the	graphic	window.

	

1.	 On	the	Profile	toolbar,	click	Circle	drop-down	>	Three	Point	Arc.

2.	 Click	to	define	the	start	point	of	the	arc.
3.	 Move	the	pointer	and	click	to	define	a	point	on	the	periphery	of	the	arc.
4.	 Again,	click	to	define	the	end	point.

	Three	Point	Arc	Starting	with	Limits
This	command	creates	an	arc	by	defining	its	start,	end,	and	radius.

	



1.	 On	 the	 Profile	 toolbar,	 click	Circle	 drop-down	 >	 Three	 Point	 Arc	 Starting	 with
Limits.

2.	 Click	to	define	the	start	point	of	the	arc.
3.	 Move	the	pointer	and	click	again	to	define	the	end	point.
4.	 After	defining	the	start	and	end	of	the	arc,	you	need	to	the	define	size	of	the	arc.	Move

the	pointer	and	click	to	define	the	radius	of	the	arc.

	Arc
This	command	creates	an	arc	by	defining	its	center,	start	and	end.

	

1.	 On	the	Profile	toolbar,	click	Circle	drop-down	>	Arc.
2.	 Click	to	define	the	center	point.
3.	 Next,	move	the	pointer	and	you	will	notice	that	a	circle	appears	attached	to	the	pointer.

This	defines	the	radius	of	the	arc.
4.	 Now,	click	to	define	the	start	point	of	the	arc	and	move	the	pointer;	you	will	notice	that

an	arc	is	drawn	from	the	start	point.
5.	 Once	the	arc	appears	the	way	you	want,	click	to	define	its	end	point.

	Circle
This	is	the	most	common	way	to	draw	a	circle.

	

1.	 Click	the	Circle	icon	on	the	Profile	toolbar,	(or)	click	Insert	>	Profile	>	Circle	>
Circle	on	the	menu.

2.	 Click	to	define	the	center	point	of	the	circle.
3.	 Drag	the	pointer,	and	then	click	again	to	define	the	diameter	of	the	circle.



	

	Three	Point	Circle
This	command	creates	a	circle	by	using	three	points.

	

1.	 On	the	Profile	toolbar,	click	Circle	drop-down	>	Three	Point	Circle.
2.	 Select	three	points	from	the	graphics	window.	You	can	also	select	existing	points	from

the	sketch	geometry.	The	first	two	points	define	the	location	of	the	circle	and	the	third
point	defines	its	diameter.

	Tri-Tangent	Circle
This	command	creates	a	circle	tangent	to	three	lines,	arcs,	or	circles.

	

1.	 On	the	Profile	toolbar,	click	Circle	drop-down	>	Tri-Tangent	Circle.
2.	 Select	three	lines,	arcs	or	circles.	This	creates	a	circle	tangent	to	selected	lines.

	Circle	Using	Coordinates
This	command	creates	a	circle	by	using	the	coordinate	values	of	its	center	point	and	the
radius	value	that	you	specify.

	

1.	 On	the	Profile	toolbar,	click	Circle	drop-down	>	Circle	Using	Coordinates.
2.	 On	the	Circle	Definition	dialog,	type-in	values	in	the	X,	Y	and	Radius	boxes.



	

	

3.	 Click	OK	to	create	the	circle.

	Rectangle
This	command	creates	a	rectangle	by	defining	its	diagonal	corners.

	

1.	 On	the	Profile	toolbar,	click	the	Rectangle	icon.
2.	 Click	to	define	the	first	corner.
3.	 Drag	the	pointer	and	click	to	define	the	second	corner.

	Oriented	Rectangle
This	 command	 creates	 an	 inclined	 rectangle.	 The	 first	 two	 points	 define	 the	width	 and
inclination	angle	of	the	rectangle.	The	third	point	defines	its	height.



	

Centered	Rectangle
This	command	creates	a	rectangle	by	defining	two	points:	center	of	the	rectangle	and	its
corner.

	

1.	 On	the	Profile	toolbar,	click	Rectangle	drop-down	>	Centered	Rectangle.
2.	 Click	to	define	the	center	of	the	rectangle.
3.	 Move	the	pointer	and	click	again	to	define	the	corner	point.

	Parallelogram
This	command	creates	a	parallelogram	by	using	three	points	that	you	specify.

	

1.	 On	the	Profile	toolbar,	click	Rectangle	drop-down	>	Parallelogram.
2.	 Select	two	points	to	define	the	width	of	the	parallelogram.
3.	 Drag	the	pointer	and	click	to	define	the	height	of	parallelogram.

	

	Centered	Parallelogram
This	command	creates	a	parallelogram	by	selecting	two	intersecting	lines.	The	point	of
intersection	will	become	the	center	of	the	parallelogram.

	

1.	 On	the	Profile	toolbar,	click	Rectangle	drop-down	>	Centered	Parallelogram.
2.	 Select	two	intersecting	lines.
3.	 Drag	the	pointer	and	click	to	define	the	corner	of	the	parallelogram.



	Polygon
This	command	provides	a	simple	way	to	create	a	closed	profile	with	equal	length	sides.

	

1.	 On	the	Profile	toolbar,	click	Rectangle	drop-down	>	Polygon.
2.	 Click	to	define	the	center	point	of	the	polygon.	The	pointer	will	be	on	one	of	the

vertices	of	the	polygon.	This	is	because	the	Circum	Circle	 option	is	activated	on	the
Sketch	Tools	toolbar.

3.	 Click	the	In	Circle	 icon	on	the	Sketch	Tools	toolbar.	The	pointer	will	be	on	one	of
the	flat	sides	of	the	hexagon.

4.	 Drag	the	pointer	and	click	to	define	the	size	and	angle	of	the	polygon.
5.	 Type	a	value	in	the	Number	of	Sides	box	on	the	Sketch	Tools	toolbar,	and	then	press

Enter.

	Elongated	Hole
This	command	creates	a	straight	slot	by	defining	its	centerline	and	radius.

	

1.	 On	the	Profile	toolbar,	click	Rectangle	drop-down	>	Elongated	Hole.
2.	 Click	to	define	the	start	point	of	the	slot.
3.	 Drag	the	pointer	and	click	to	define	the	end-point.	This	creates	the	centerline	of	the

slot.
4.	 Now,	drag	the	pointer	and	click	to	define	the	radius	of	the	slot.

	



	Cylindrical	Elongated	Hole
This	command	creates	a	curved	slot	by	defining	the	curve	radius	and	slot	radius.	First,	you
have	to	create	an	arc,	and	then	create	a	slot	along	the	arc.

	

1.	 On	the	Profile	toolbar,	click	Rectangle	drop-down	>	Cylindrical	Elongated	Hole.
2.	 Click	to	define	the	center	point	of	the	arc.
3.	 Drag	the	pointer	and	define	the	start	and	end	points	of	the	arc.	This	defines	the	radius

and	size	of	the	center	arc.
4.	 Now,	drag	the	pointer	and	click	to	define	the	radius	of	the	slot.

	Keyhole	Profile
This	 command	 creates	 a	 keyhole	 profile.	 A	 keyhole	 profile	 has	 a	 large	 and	 small	 arcs
connected	through	a	slot.

	

1.	 On	the	Profile	toolbar,	click	Rectangle	drop-down	>	Keyhole	Profile.
2.	 Click	to	define	the	center	point	of	the	large	arc.
3.	 Drag	the	pointer	and	click	to	define	the	center	point	of	the	small	arc.

4.	 Now,	drag	the	pointer	and	click	to	define	the	small	radius.



5.	 Again,	drag	the	pointer	and	click	to	define	the	large	radius.

	Line
This	command	creates	a	line	using	the	start	and	endpoints	that	you	select.

	

1.	 On	the	Profile	toolbar,	click	Line	drop-down	>	Line.
2.	 Click	the	start	and	endpoints	of	the	line.

	If	you	want	to	define	its	midpoint	and	endpoint,	then	click	Symmetrical	Extension
on	the	Sketch	tools	toolbar.	Define	the	mid	and	endpoints	of	the	straight	line.



	Infinite	Line
This	command	creates	a	line	with	infinite	length.

	

1.	 On	the	Profile	toolbar,	click	Line	drop-down	>	Infinite	Line.
2.	 On	the	Sketch	tools	toolbar,	click	the	Line	Through	Two	Points	 icon.
3.	 Click	to	define	the	origin	of	the	line.
4.	 Drag	the	pointer	to	rotate	the	line.
5.	 Click	to	create	an	infinite	line	at	an	angle.

	

If	you	want	to	create	a	horizontal	or	vertical	infinite	line,	click	the	Horizontal	or	Vertical
button	on	the	Sketch	tools	toolbar.

	

	

	Bi-Tangent	Line
This	command	creates	a	line	tangent	to	two	circles	or	arcs.

	

1.	 On	the	Profile	toolbar,	click	Line	drop-down	>	Bi-Tangent	Line.
2.	 Select	two	circles	or	arcs.	This	creates	a	line	tangent	to	the	selected	elements.

	Bisecting	Line
This	command	creates	an	infinite	line	passing	through	the	intersection	of	two	lines.	In	case



of	parallel	lines,	an	infinite	line	will	be	created	at	the	center	and	parallel	to	both	the	lines.

	

1.	 On	the	Profile	toolbar,	click	Line	drop-down	>	Bisecting	Line.
2.	 Select	two	lines.

	Line	Normal	to	Curve
This	command	creates	a	line	normal	to	arc,	ellipse,	circle,	spline	or	any	other	curve.

	

1.	 On	the	Profile	toolbar,	click	Line	drop-down	>	Line	Normal	to	Curve.
2.	 Click	on	the	curve	to	draw	a	normal	line.
3.	 Drag	the	pointer	and	click	to	define	the	endpoint	of	the	line.

	Axis
This	 command	 creates	 a	 sketch	 axis,	 which	 can	 be	 used	 while	 creating	 the	 revolved
feature.

	

1.	 On	the	Profile	toolbar,	click	the	Axis	icon.
2.	 Define	the	start	and	endpoints	of	the	axis.

You	can	also	convert	an	existing	line	into	an	axis	by	selecting	it	and	clicking	the	Axis	icon
on	the	Profile	toolbar.



	

	Ellipse
This	command	creates	an	ellipse	using	a	center	point,	and	major	and	minor	axes.

	

1.	 On	the	Profile	toolbar,	click	Ellipse	drop-down	>	Ellipse.
2.	 Click	to	define	the	center	of	the	ellipse.
3.	 Drag	the	pointer	and	click	to	define	the	major	axis	and	orientation	of	the	ellipse.
4.	 Drag	the	pointer	and	click	again	to	define	the	minor	axis.

On	the	Sketch	tools	toolbar,	you	can	also	type-in	values	in	the	Major	Radius,	Minor
Radius,	and	A	(angle)	boxes.

	

	Points	by	Clicking
This	command	creates	points	as	you	click	in	the	graphics	window.	

	

1.	 On	the	Profile	toolbar,	click	Points	drop-down	>	Points	by	Clicking.
2.	 Click	in	the	graphics	window	to	create	points.

	

	Point	by	Using	Coordinates
This	command	creates	a	point	by	entering	its	coordinate	values	in	the	Cartesian	or	Polar
coordinate	system.

	

1.	 On	the	Profile	toolbar,	click	Points	drop-down	>	Points	by	Using	Coordinates.
2.	 On	the	Point	Definition	dialog,	click	the	Cartesian	tab	and	type-in	values	in	the	H

and	V	boxes.

	



	

3.	 If	you	want	to	enter	the	coordinate	values	in	the	Polar	coordinate	system,	then	click	the
Polar	tab	and	type-in	values	in	the	Radius	and	Angle	boxes.

	

	

	Equidistant	Points
This	command	creates	equidistant	points	on	a	selected	sketch	element.

	

1.	 On	the	Profile	toolbar,	click	Points	drop-down	>	Equidistant	Points.
2.	 Select	a	sketch	element.

3.	 On	the	Equidistant	Point	Definition	dialog,	type-in	a	value	in	the	New	Points	box.
4.	 If	you	want	to	reverse	the	side	of	point	creation,	then	click	the	Reverse	Direction

button.

	



	

5.	 Click	OK	to	complete	the	point	creation.

	Intersection	Point
This	command	creates	a	point	at	the	intersection	of	two	elements.

	

1.	 On	the	Profile	toolbar,	click	Point	drop-down	>	Intersection	Point.
2.	 Click	on	two	intersecting	elements.

	Projection	Point
This	command	creates	a	new	point	by	projecting	a	point	onto	a	sketch	element.

	

1.	 On	the	Profile	toolbar,	click	Point	drop-down	>	Projection	Point.
2.	 Click	on	the	point	to	be	projected.
3.	 Click	on	the	sketch	element	onto	which	the	point	will	be	projected.



Align	Points
This	command	aligns	a	point	along	a	straight	line.

	

1.	 On	the	Profile	toolbar,	click	Point	drop-down	>	Align	Points.
2.	 Click	on	the	point	to	be	aligned.
3.	 Select	another	point	or	click	to	define	the	alignment	direction.	A	straight	construction

line	is	created	and	the	selected	point	is	aligned	along	the	line.

	

	Spline
This	command	creates	a	smooth	B-spline	curve	passing	through	the	points	you	select.

	

1.	 On	the	Profile	toolbar,	click	Spline	drop-down	>	Spline.
2.	 Click	to	define	points	in	the	graphics	window.	This	creates	a	spline	passing	through	the

selected	points.
3.	 Press	Esc	to	deactivate	this	command.

If	you	want	to	create	a	closed	spline,	then	click	the	right	mouse	button	and	select	Close
spline.

	Connect
This	command	connects	two	splines	or	curves.

	



1.	 On	the	Profile	toolbar,	click	Spline	drop-down	>	Connect.
2.	 Click	on	two	open	curves	to	connect	them.

On	 the	Sketch	tools	 toolbar,	 you	 can	 define	 the	 type	 of	 connecting	 curve	 by	 using	 the
Connect	with	an	Arc	and	Connect	with	a	Spline	button.	If	you	click	the	Connect	with	a
Spline	button,	then	you	can	define	the	continuity	of	the	bridge	curve	using	the	Continuity
in	point,	Continuity	 in	tangency,	and	Continuity	 in	curvature	buttons.	The	following
examples	show	the	continuity	types.

	The	Constraint	command
It	is	generally	considered	a	good	practice	to	ensure	that	every	sketch	you	create	is	fully
constrained	before	moving	on	to	creating	features.	The	term,	‘fully-constrained’	means
that	the	sketch	has	a	definite	shape	and	size.	You	can	fully-constrain	a	sketch	by	using
dimensions	and	constraints.	You	can	add	dimensions	to	a	sketch	by	using	the	Constraint
command	(on	the	Constraint	toolbar,	click	Constraint	drop-down	>	Constraint).	You
can	use	this	command	to	add	all	types	of	dimensional	constraints	such	as	length,	angle,
and	diameter	and	so	on.	This	command	creates	a	dimension	based	on	the	geometry	you



select.	For	instance,	to	dimension	a	circle,	activate	the	Constraint	command,	and	then
click	on	the	circle.	Next,	move	the	pointer	and	click	again	to	position	the	dimension.

Now,	you	can	change	the	size	of	the	sketch	element	by	modifying	the	dimension	value.	To
do	this,	double-click	on	the	dimension.	You	will	notice	that	the	Constraint	Definition
dialog	pops	up.	Type-in	a	value	in	this	box,	and	click	OK	to	update	the	dimension.

	

	

If	you	click	a	line,	this	command	automatically	creates	a	linear	dimension.	Click	once
more	to	position	the	dimension.

	

If	you	click	on	an	inclined	line,	this	command	creates	a	dimension	parallel	to	the	line.



If	you	want	to	create	a	horizontal	dimension,	then	click	the	right	mouse	button	and	select
Horizontal	Measure	Direction.

Likewise,	if	you	want	to	create	a	vertical	dimension,	then	click	the	right	mouse	button	and
select	Vertical	Measure	Direction.

If	you	want	to	create	an	angle	dimension	between	two	elements,	then	activate	the
Constraint	command	and	select	the	elements.	Next,	move	the	pointer	and	position	the
dimension.

Over-constrained	Sketch
When	creating	sketches	for	a	part,	CATIA	V5	will	not	allow	you	to	over-constrain	the
geometry.	The	term	‘over-constrain’	means	adding	more	dimensions	than	required.		The
following	figure	shows	a	fully	constrained	sketch.	If	you	add	another	dimension	to	this
sketch	(e.g.	diagonal	dimension),	the	elements	and	dimensions	affected	by	the	additional
dimension	will	turn	into	magenta	color.

Now,	you	have	to	deactivate	one	of	the	dimensions.	Click	the	right	mouse	button	on	the



diagonal	dimension	and	select	object	>	Deactivate	to	deactivate	the	dimension.	The
deactivated	dimension	will	be	in	black	color.

	

Now,	if	you	change	the	value	of	the	width,	the	inactive	dimension	along	the	diagonal
updates,	automatically.	Also,	note	that	the	dimensions,	which	are	initially	created,	will	be
driving	dimensions,	whereas	the	dimensions	created	after	fully	defining	the	sketch	are
over	constraining	dimensions.

	

	Auto	Constraint
This	command	automatically	creates	dimensions	and	fully	constrains	the	sketch.	

	

1.	 On	the	Constraint	toolbar,	click	Fix	together	>	Auto	Constraint.
2.	 Press	the	left	mouse	button	and	drag	a	selection	box	around	the	sketch.

3.	 Click	OK	on	the	Auto	Constraint	dialog.



If	you	want	to	create	chained	dimensions,	then	select	the	complete	sketch	and	click	in	the
Reference	elements	selection	box.	Click	on	the	longest	element	of	the	sketch	to	define	the
reference	element.	On	the	Auto	Constraint	dialog,	select	Constraint	mode	>	Chained	to
create	chained	dimensions.

Likewise,	use	Constraint	Mode	>	Stacked	to	create	stacked	dimensions.

Edit	Multi-Constraint
This	command	modifies	all	 the	constraints	 in	a	sketch	using	 the	Edit	Multi-Constraint
dialog.

	



1.	 On	the	Constraint	toolbar,	click	the	Edit	Multi-Constraint	icon.
2.	 On	Edit	Multi-Constraint	dialog,	select	the	dimensions	and	type-in	a	value	in	the

Current	Value	box.	For	example,	to	change	the	radius	value	of	the	arc	shown	in
figure,	select	the	Radius	dimension	and	type-in	a	new	value	in	the	Current	value	box.

	

3.	 If	required,	you	can	type-in	the	maximum	and	minimum	tolerance	values.
4.	 Click	OK	to	update	the	dimension.

Contact	Constraint
This	command	establishes	contact	between	the	sketch	elements	based	on	the	selection.

	

1.	 On	the	Constraint	toolbar,	click	Constraint	>	Contact	Constraint.



2.	 Select	two	points	to	make	them	coincident.

3.	 Select	a	curve	and	line	to	make	them	tangent	to	each	other.

4.	 Select	a	line	or	curve	and	point	to	make	them	coincident.

5.	 Select	two	lines	to	make	them	collinear.

	

6.	 Select	two	circles	or	arcs	to	make	them	concentric.

	



	Constraints	Defined	in	Dialog
In	addition	to	dimensional	and	contact	constraints,	there	are	other	constraints,	which	you
can	establish	between	the	sketch	elements.	You	can	do	this	using	the	Constraints	Defined
in	Dialog	command.

	

1.	 Press	and	hold	the	Ctrl	key	and	click	on	two	points.
2.	 On	the	Constraint	toolbar,	click	the	Constraints	Defined	in	Dialog	icon.
3.	 On	the	Constraint	Definition	dialog,	check	the	Distance	option	to	establish	a	distance

constraint	between	two	points.

4.	 If	you	want	to	make	the	two	points	coincident	with	each	other,	then	uncheck	the
Distance	option.

5.	 Check	the	Coincidence	option.

To	fix	a	sketch	element	(or	elements)	at	its	current	location,	select	it	and	activate	the
Constraints	Defined	in	Dialog	command.

On	the	Constraint	Definition	dialog,	check	the	Fix	option.

To	apply	the	Length	constraint,	select	a	linear	element	and	activate	the	Constraint
Defined	in	Dialog	command.	Check	the	Length	option	on	the	Constraint	Definition
dialog.



	

To	apply	the	Horizontal	constraint,	select	a	linear	element	and	activate	Constraint
Defined	in	Dialog	command.	Check	the	Horizontal	option.

	

Likewise,	use	the	Vertical	option	to	make	a	line	vertical.

	

Use	the	Parallelism	option	to	make	two	lines	parallel	to	each	other.



	

Use	the	Perpendicular	option	to	make	two	lines	perpendicular	to	each	other.

	

	

Use	the	Midpoint	option	to	make	a	point	coincide	with	the	midpoint	of	a	line.

	

	

Use	the	Symmetry	option	to	make	two	sketch	elements	symmetric	about	a	centerline.
Press	the	Ctrl	key	and	click	on	the	elements	to	make	symmetric.		Click	on	the	symmetric
line	and	activate	the	Constraint	Defined	in	Dialog	command.



On	the	Constraint	Definition	dialog,	check	the	Symmetry	option	and	click	OK.

	

You	can	also	create	multiple	constraints	between	two	elements.	To	do	so,	check	the	Target
Element	option,	click	in	Target	Element	selection	box,	and	select	the	target	element.
Select	the	constraints	from	the	Constraint	Definition	dialog.

	

	The	Fix	Together	command
This	relation	makes	the	selected	elements	act	as	a	single	unit.

	

1.	 On	the	Constraint	toolbar,	click	the	Fix	Together	icon.
2.	 Select	two	or	more	elements	from	the	sketch.
3.	 Click	OK	on	the	Fix	Together	Definition	dialog.	The	selected	objects	will	form	a	rigid

set.



Now,	click	and	drag	anyone	of	the	object	from	the	rigid	set.	You	will	notice	that	entire	set
will	be	dragged.

	

	Display	Geometrical	Constraints
As	constraints	are	created,	they	can	be	shown	or	hidden	using	the	Geometrical
Constraints	icon	on	the	Visualization	toolbar.	When	dealing	with	complicated	sketches
involving	numerous	constraints,	you	can	deactivate	this	button	to	turn	off	the	display	of	all
geometrical	constraints.

	

	



	Sketch	Solving	Status
At	any	stage	of	the	design	process,	you	can	check	whether	the	sketch	is	fully	constrained
or	not	by	viewing	the	sketch	color.	However,	you	can	also	use	the	Sketch	Solving	Status
command	to	check	the	status	of	the	sketch.	Activate	this	command	(On	the	Tools	toolbar,
click	the	Sketch	Solving	Status	icon)	to	view	the	sketch	status.	

	

	Sketch	Analysis
This	command	can	be	used	to	analyse	the	sketch.	For	example,	the	following	figure	shows
an	over-constrained	sketch.

1.	 To	analyse	this	sketch,	activate	the	Sketch	Analysis	command	(on	the	Tools	toolbar,
click	2D	Analysis	drop-down	>	Sketch	Analysis).

2.	 On	the	Sketch	Analysis	dialog,	click	the	Diagnostics	tab.
3.	 Under	the	Solving	Status	section,	select	the	constraint	marked	as	Over-constrained.
4.	 Under	the	Action	section,	click	the	Delete	geometry	or	constraint	 button.
5.	 Close	the	dialog.



	Construction/Standard	Element
This	command	converts	a	standard	sketch	element	into	a	construction	element.
Construction	elements	support	you	to	create	a	sketch	of	a	desired	shape	and	size.	To
convert	a	standard	sketch	element	to	construction	element,	click	on	it	and	select
Construction/Standard	Element	on	the	Sketch	tools	toolbar.

You	can	also	convert	it	back	to	a	standard	sketch	element	by	right	clicking	on	it	and
selecting	Geometrical	Element.

	



	

	The	Corner	command
This	command	rounds	a	sharp	corner	created	by	intersection	of	two	lines,	arcs,	circles,	and
rectangle	or	polygon	vertices.

	

1.	 On	the	Operation	toolbar,	click	the	Corner	icon	(or)	click	Insert	>	Operation	>
Corner	>	Corner.

2.	 Select	the	intersecting	elements	to	add	a	corner.

3.	 Type-in	a	radius	value	in	the	Radius	box	available	on	the	Sketch	tools	toolbar.
4.	 Press	Enter.

The	elements	to	be	cornered	are	not	required	to	touch	each	other.



By	default,	the	elements	are	automatically	trimmed	or	extended	to	meet	the	end	of	the	new
corner	radius.	You	can	use	the	Trim	first	Element	option	on	the	Sketch	tools	toolbar,	if
you	want	to	trim	only	the	first	element.

Use	the	No	Trim	option	on	the	Sketch	tools	toolbar,	if	you	do	not	want	to	trim	or	extend
the	elements	as	necessary.

The	other	trim	options	are:



	The	Chamfer	command
This	command	replaces	a	sharp	corner	with	an	angled	line.

	

1.	 On	the	Operations	toolbar,	click	the	Chamfer	icon.
2.	 Select	the	select	the	elements’	ends	to	be	chamfered.

3.	 Type-in	the	chamfer	angle	and	length	in	the	Angle	and	Length	boxes	on	the	Sketch
Tools	toolbar,	respectively.

4.	 Press	Enter	to	create	the	chamfer.

	The	Quick	Trim	command
This	command	trims	the	end	of	an	element	back	to	the	intersection	of	another	element.

	

1.	 On	the	Operations	toolbar,	click	Relimitations	drop-down	>	Quick	Trim.
2.	 Click	on	the	element	to	trim.



	The	Break	command
This	command	breaks	a	sketch	element	at	a	selected	point.

	

1.	 On	the	Operations	toolbar,	click	Relimitations	drop-down	>	Break.
2.	 Select	the	element	to	break.
3.	 Click	to	define	the	break	point.

	

	

	The	Close	Arc	command
This	command	closes	the	open	arc.

	

1.	 On	the	Operations	toolbar,	click	Relimitations	drop-down	>	Close	Arc.
2.	 Click	on	an	arc	to	convert	it	into	a	circle.

	The	Complement	command
This	command	shows	the	complementary	side	of	an	arc.

	

1.	 On	the	Operations	toolbar,	click	Relimitations	drop-down	>	Complement.
2.	 Click	on	an	arc	to	show	the	complementary	side	of	it.



	The	Trim	command
This	command	trims	and	extends	elements	to	form	a	corner.

	

1.	 On	the	Operations	toolbar,	click	Relimitations	drop-down	>	Trim.
2.	 Select	two	intersecting	elements.	The	elements	will	be	trimmed	and	extended	to	form	a

closed	corner.

	The	Mirror	command
This	command	creates	a	mirror	copy	of	the	selected	sketch	elements.

	

1.	 On	the	Operations	toolbar,	click	Transformation	drop-down	>	Mirror.
2.	 Drag	a	selection	box	and	select	the	elements	to	mirror.



3.	 Click	on	a	line	or	axis	to	define	the	mirror	line.

	The	Symmetry	command
This	command	creates	a	mirror	image	of	selected	sketch	elements	without	copying	them.

	

1.	 On	the	Operations	toolbar,	click	Transformation	drop-down	>	Symmetry.
2.	 Click	on	the	element	to	mirror	(or)	drag	a	selection	box	to	select	multiple	elements	at	a

time.
3.	 Click	on	the	line	or	axis	about	which	the	element	will	be	mirrored.

	

	The	Translate	command
This	command	relocates	one	or	more	elements	from	one	position	in	the	sketch	to	any	other
position	you	specify.

	

1.	 On	the	Operations	toolbar,	click	Transformation	drop-down	>	Translate.
2.	 Click	on	the	elements	to	translate.
3.	 Click	to	define	the	start	point	of	the	translation.



4.	 On	the	Translation	Definition	dialog,	check	the	Duplicate	mode	if	you	want	to	copy
and	move	the	selected	element(s).	Next,	type-in	the	number	of	instances	to	be	created
in	the	Instance	box.

	

	

5.	 On	the	Translation	Definition	dialog,	check	the	Keep	internal	constraints	and	Keep
external	constraints	options	to	copy	the	constraints	of	the	selected	element	as	well.
Check	the	Keep	original	constraint	mode	option,	if	you	want	to	copy	the	element
with	it	original	constraints.

6.	 Move	the	pointer	and	click	to	define	the	translation	distance	(or)	type-in	a	value	in	the
Length	box	on	the	Translation	Definition	dialog.



	

	The	Rotate	command
This	command	rotates	the	selected	elements	to	any	position.

	

1.	 On	the	Operations	toolbar,	click	Transformation	drop-down	>	Rotate.
2.	 Select	the	elements	to	rotate.
3.	 Click	to	define	the	center	point	of	the	rotation.
4.	 Move	the	cursor	and	click	to	define	a	reference	line	for	rotation	angle.

5.	 On	the	Rotation	Definition	dialog,	check	the	Duplicate	mode	if	you	want	to	copy	and
rotate	the	selected	element(s).	Next,	type-in	the	number	of	instances	to	be	created	in
the	Instance	box.

	

	

6.	 On	 the	Rotation	Definition	 dialog,	 check	 the	Keep	 constraints	 option	 to	 copy	 the
constraints	of	the	selected	element	as	well.

7.	 Move	the	pointer	and	click	to	define	the	rotation	angle	(or)	type-in	a	value	in	the	Value
box	on	the	Rotation	Definition	dialog.



	

	The	Scale	command
This	command	increases	or	decreases	the	size	of	elements	in	a	sketch.

	

1.	 On	the	Operations	toolbar,	click	Transformation	drop-down	>	Scale.
2.	 Select	the	elements	to	scale.
3.	 Select	a	base	point.
4.	 Scale	the	size	of	the	selected	elements	by	moving	the	pointer	or	typing-in	a	scale	value

in	the	Value	box	on	the	Scale	Definition	dialog.

	The	Offset	Curve	command



This	command	creates	a	parallel	copy	of	a	selected	element	or	chain	of	elements.

	

1.	 On	the	Operations	toolbar,	click	Transformation	drop-down	>	Offset.
2.	 Click	on	the	sketch	element	to	offset.

	

Use	the	No	Propagation	option	on	the	Sketch	tools	toolbar	to	select	a	single	element.

Use	the	Tangent	Propagation	option	to	select	tangentially	connected	elements.

Use	the	Point	Propagation	option	to	select	all	the	connected	elements	in	a	single	click.

Use	the	Both	Sides	offset	option	to	offset	the	sketch	elements	on	both	sides.



3.	 Type-in	a	value	in	the	Offset	box	available	on	the	Sketch	tools	toolbar.
4.	 If	you	want	to	create	more	than	one	offset	copy,	then	type-in	a	value	in	the	Instance

box	available	on	the	Sketch	tools	toolbar.
5.	 Press	Enter	to	create	the	offset	copy.



Examples
Example	1
In	this	example,	you	will	draw	the	sketch	shown	below.

1.	 Start	CATIA	V5-6R2015	by	clicking	the	CATIA	V5-6R2015	icon	on	your	desktop.
2.	 On	the	Standard	toolbar,	click	the	New	 icon.
3.	 On	the	New	dialog,	click	List	of	Types	>	Part	and	click	OK.
4.	 Click	OK	on	the	New	Part	dialog.
5.	 Click	Sketch	 icon	on	the	Sketcher	toolbar	(or)	Insert	>	Sketcher	>	Sketch	on

the	Menu.
6.	 Click	on	the	YZ	plane	to	start	the	sketch.

7.	 On	the	Sketch	tools	toolbar,	deactivate	the	Snap	to	Point	 icon
8.	 On	the	Profile	toolbar,	click	the	Profile	 icon.
9.	 Click	on	the	origin	point	to	define	the	first	point	of	the	line.
10.	 Move	the	pointer	rightwards	and	click.

11.	 Move	the	pointer	upwards	and	click.

12.	 Move	the	pointer	rightwards	and	click.



13.	 Create	a	closed	loop	by	selecting	points,	as	shown	below.

14.	 On	the	Constraints	toolbar,	click	the	down	arrow	next	to	the	Constraints	icon	and
select	the	Contact	Constraint	icon	(or)	Insert	>	Constraint	>	Constraint
Creation	>	Contact	Constraint	on	the	Menu.

15.	 Click	on	the	two	horizontal	lines	at	the	bottom;	they	become	collinear.

16.	 On	the	Constraint	toolbar,	double-click	the	Constraint	 icon	and	click	on	the
lower	horizontal	line.

17.	 Move	the	pointer	downward	and	click	to	position	the	dimension.



18.	 Click	on	the	small	vertical	line.
19.	 Move	the	pointer	and	click	to	position	the	dimension.

20.	 Likewise,	create	other	dimensions,	as	shown	below.

21.	 On	the	Constraints	toolbar,	click	the	Edit	Multi-Constraint 	icon.
22.	 Click	on	the	horizontal	dimension,	as	shown	in	figure.



23.	 Type	120	in	the	Current	Value	box	and	click	the	Preview	button.

24.	 Likewise,	change	the	other	dimensional	values.	Click	OK	on	the	dialog.

25.	 On	the	Profile	toolbar,	click	Circle	 icon.
26.	 Click	inside	the	sketch	region	to	define	the	center	point	of	the	circle.	Move	the

pointer	and	click	to	define	the	diameter.	Likewise,	create	another	circle.



27.	 On	the	Constraints	toolbar,	click	the	Constraints	icon	and	apply	dimensions	to
fully	constraint	the	circles.

28.	 Activate	the	Edit	Multi-Constraint	command	and	modify	the	dimension	values	of
the	circles.

29.	 On	the	Workbench	toolbar,	click	Exit	Workbench	 .
30.	 On	 the	 Standard	 toolbar,	 click	 the	 Save	 icon	 (or)	 click	 File	 >	 Save	 on	 the

Menu.
31.	 On	the	Save	As	dialog,	type-in	C2_example1	in	the	File	name	box.	Define	the

location	and	click	Save	to	save	the	part	file.
32.	 Click	Close	Window	on	the	top	right	corner	to	close	the	part	file.

	

Example	2
In	this	example,	you	will	draw	the	sketch	shown	below.



1.	 Start	CATIA	V5-6R2015	by	clicking	the	CATIA	V5-6R2015	icon	on	your	desktop.
2.	 On	the	Standard	toolbar,	click	the	New	icon.
3.	 On	the	New	dialog,	click	List	of	Types	>	Part	and	click	OK.
4.	 Click	OK	on	the	New	Part	dialog.
5.	 To	start	a	new	sketch,	click	the	Sketch	icon	on	the	Sketcher	toolbar.
6.	 Click	on	the	XY	Plane	to	start	the	sketch.

7.	 On	the	Profile	toolbar,	click	the	Profile	icon.
8.	 Click	 in	 the	second	quadrant	of	 the	coordinate	system	to	define	 the	start	point	of	 the

profile.	Drag	the	pointer	horizontally	and	click	to	define	the	endpoint.

9.	 On	the	Sketch	tools	toolbar,	click	the	Three	Point	Arc	 	icon.
10.	 Move	the	pointer	upwards	right	and	click	to	define	the	second	point	of	the	arc.

11.	 Move	the	pointer	and	click	to	define	the	third	point	of	the	arc,	as	shown.

12.	 On	the	Sketch	tools	toolbar,	click	the	Tangent	Arc	 	icon.
13.	 Move	the	pointer	upwards	and	click	to	create	an	arc	tangent	to	the	previous	arc.



14.	 Move	the	pointer	toward	left	and	click	to	create	a	horizontal	line.

15.	 Click	the	Tangent	Arc	icon	the	Sketch	tools	toolbar.
16.	 Move	the	pointer	downwards	and	click	when	a	vertical	dotted	line	appears,	as	shown

below.

17.	 Click	the	Tangent	Arc	icon	on	the	Sketch	tools	toolbar.	Move	the	pointer	downward
right	and	click	on	the	origin	to	close	the	sketch.



18.	 Press	Esc	to	deactivate	the	Profile	command.
19.	 Activate	the	Circle	command	and	draw	a	circle	on	the	right	side.
20.	 Press	the	Ctrl	key	and	click	on	the	circle	and	the	small	arc.

21.	 On	the	Constraints	toolbar,	click	the	Constraints	Defined	in	Dialog 	icon.
22.	 On	the	Constraints	Definition	dialog,	check	the	Concentricity	option	and	click	OK.

The	circle	and	arc	are	made	concentric.

23.	 On	the	Operation	toolbar,	click	the	Mirror	 	icon	(or)	click	Insert	>	Operation	>
Transformation	>	Mirror.

24.	 Click	on	the	small	circle	and	the	vertical	axis.	A	mirror	copy	of	the	circle	is	created.



25.	 Apply	the	Concentricity	constraint	between	the	new	circle	and	arc	on	left	side.

26.	 Press	the	Ctrl	key	and	select	the	small	arcs,	and	then	click	on	the	vertical	axis.

27.	 On	the	Constraints	toolbar,	click	the	Constraints	Defined	in	Dialog	 icon.
28.	 On	the	Constraints	Definition	dialog,	check	the	Symmetry	option	and	click	OK.	The

two	arcs	are	made	symmetric	about	the	vertical	axis.

29.	 Likewise,	make	the	large	arcs	symmetrical	about	the	vertical	axis.



	

30.	 Press	the	Ctrl	key	and	click	the	bottom	horizontal	line	and	the	horizontal	axis.
31.	 Activate	the	Constraints	Defined	in	Dialog	command	and	check	the	Coincidence

option	on	the	Constraint	Definition	dialog.
32.	 Click	OK	to	make	the	horizontal	line	coincide	with	the	horizontal	axis.

33.	 Press	and	hold	the	Ctrl	key.
34.	 Click	on	the	center	point	of	the	large	arc	and	the	horizontal	line	at	the	bottom.

35.	 Activate	the	Constraints	Defined	in	Dialog	command	and	check	the	Coincidence
option	on	the	Constraint	Definition	dialog.

36.	 Click	OK	to	make	the	center	point	of	the	large	arc	coincident	with	the	horizontal	line,



37.	 On	the	Constraints	toolbar,	double-click	the	Constraints	icon	and	apply	dimensions
to	the	sketch,	as	shown	below.

	

38.	 Activate	the	Edit	Multi-Constraint	command	and	change	the	dimensional	values.

39.	 Click	Exit	workbench	to	complete	the	sketch.
40.	 To	save	the	file,	click	File	>	Save	on	the	Menu.
41.	 On	the	Save	As	dialog,	type-in	C2_example2	in	the	File	name	box.	Define	the

location	and	click	Save	to	save	the	part	file.
42.	 To	close	the	file,	click	File	>	Close	on	the	Menu.



Questions
1.	 What	is	the	procedure	to	create	sketches	in	CATIA	V5?
2.	 List	any	two	sketch	constraints	in	CATIA	V5.
3.	 Which	command	creates	constraints	automatically?
4.	 Describe	the	method	to	create	an	ellipse.
5.	 How	do	you	define	the	shape	and	size	of	a	sketch?
6.	 How	do	you	create	a	tangent	arc	using	the	Profile	command?
7.	 Which	 command	 is	 used	 to	 apply	 different	 types	 of	 dimensional	 constraints	 to	 a

sketch?
8.	 List	any	two	methods	to	create	circles.
9.	 How	do	you	create	fillet	with	an	alternate	solution?

	



Exercises
Exercise	1

Exercise	2

	

Exercise	3



	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	



	
	
	
	
	
	
	
	
	





	


	Getting Started with CATIA V5-6R2015
	Introduction to CATIA V5-6R2015
	File Types in CATIA V5
	Starting CATIA V5-6R2015
	User Interface
	Standard Toolbar
	Start Menu
	Menu bar
	Toolbar
	Status bar
	Specification Tree
	Dialogs

	Background
	Shortcut Keys
	Questions

	Sketcher Workbench
	Sketching in the Sketcher Workbench
	Draw Commands
	The Profile command
	Polygon
	Elongated Hole
	Cylindrical Elongated Hole
	Keyhole Profile
	Line
	Infinite Line
	Bi-Tangent Line
	Bisecting Line
	Line Normal to Curve
	Axis
	Ellipse
	Points by Clicking
	Point by Using Coordinates
	Equidistant Points
	Intersection Point
	Projection Point
	Align Points
	Spline
	Connect

	The Constraint command
	Over-constrained Sketch
	Auto Constraint
	Edit Multi-Constraint
	Contact Constraint
	Constraints Defined in Dialog
	The Fix Together command
	Display Geometrical Constraints

	Sketch Solving Status
	Sketch Analysis
	Construction/Standard Element
	The Corner command
	The Chamfer command
	The Quick Trim command
	The Break command
	The Close Arc command
	The Complement command
	The Trim command
	The Mirror command
	The Symmetry command
	The Translate command
	The Rotate command
	The Scale command
	The Offset Curve command
	Examples
	Example 1
	Example 2

	Questions
	Exercises
	Exercise 1
	Exercise 2
	Exercise 3



